Grotesk1077
16.09.2020 19:28

1. написать программу вычисления площади кольца, где исходными данными являются радиусы кольца и отверстия. предусмотреть в программе проверку правильности исходных данных (радиус отверстия не может быть больше радиуса кольца). сделать на паскале и можно в документе прикрепить

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Полина1111111С
21.09.2020 20:52
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var r1:=abs(ReadReal('Наружный радиус кольца'));
  var r2:=abs(ReadReal('Внутренний радиус кольца'));
  if (r1*r2>0) and (r1>r2) then
    Writeln('Площадь кольца ',pi*(sqr(r1)-sqr(r2)))
  else Writeln('Неверные данные')
end.

Тестовое решение:
Наружный радиус кольца 25
Внутренний радиус кольца 21.8
Площадь кольца 470.484915801607
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота