mishelmarriano
03.01.2021 21:01

Составить программу которая выбросит из записи числа n все цифры равные 1, оставив при этом прежним порядок остальных цифр. пример 5101234-50234

Нажмите на рекламу ниже и сразу увидите ответ
↓
Ответ:
алгебра97
03.10.2020 06:41
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
begin
  var s:=ReadlnString.Where(x->x in ['0'..'9']);
  var r:=s.Where(x->x<>'1').Println('');
end.

Тестовые примеры:
5101234
50234

3,1415926535897932384626433832795028 - первые знаки числа ПИ
345926535897932384626433832795028

98765432111111111110000111111000001111111123456789
9876543200000000023456789
0,0(0 оценок)
Ответ:
vikailyina2003
03.10.2020 06:41
#include <iostream>
#include <sstream>
#include <fstream>
#include <string>
#include <vector>
#include <deque>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <algorithm>
#include <functional>
#include <cstring>
#include <utility>
#include <bitset>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <cstdio>
#include <climits>typedef unsigned long long ulol;
typedef long long lol;
typedef long int  li;#define mp          make_pair
#define F           first
#define S           second
#define sqr(a)      ( (a) * (a) )
#define pb          push_back
#define INF         999999999
#define ret(a)      cout << endl; system("pause"); return(a)
//#define ret(a)      return(a)using namespace std;int main()
{
    string s, ans;
    cin >> s;
    for(int i = 0 ; i < s.size() ; i ++)
        if( s[i] != '1' )
            ans.pb( s[i] );
    cout << ans;
    ret(0);
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота