viktoriadog
05.09.2021 21:31

Написать программу на языке паскаль . дан одновременный массив из п целых чисел .составить программу вычисления суммы элементов стоящих на четных местах

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kristaile
27.05.2020 17:58

var

M:array[0..100]of integer;

i,k,n:integer;

begin

k:=0

randomize;

write('введите кол-во элементов массива');

read(n);

for i:=1 to n do

begin

M[i]:=random (30);

if i mod 2 =0 then k:=k+M[i]

else write ('Четных элементов нет');

writeln ('Сумма четных элементов', k);

end;

end.

0,0(0 оценок)
Ответ:
rjt54
27.05.2020 17:58

var

  a : array [1..1000] of integer;

  i, n, sum : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  sum := 0;

  for i := 1 to n do

    if i mod 2 = 0 then inc (sum, a[i]);

  writeln (sum);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота