chifire
17.04.2021 18:38

1) составьте программу, меняющую в слове x букву "о" на букву "и", если "о" стоит на четном месте. 2)составьте программу, меняющую в слове х все сочетания "ва" на "к". заранее )

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Дарья16072005
21.09.2020 19:27
1.
Var 
s:string; 
i:integer;
Begin 
Write('Введите строку '); 
Readln(s); 
for i:= 1 to length(s) do   
if ((s[i]='о')or(s[i]='o'))and((i mod 2) = 0) then s[i]:='и'; 
Writeln(s); 
End.  
 
2. 
Var 
s:string; 
i,j:integer;
Begin 
Write('Введите строку '); 
Readln(s); 
s:=s+' '; 
for i:= 1 to length(s) do   
if (s[i]='в')and(s[i+1] = 'а') then Begin s[i]:='к'; for j:=(i+1) to (length(s)-1) do s[j]:=s[j+1]; end; 
Writeln(s); 
End.  
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота