Nukaka9l
08.04.2023 05:47

Составьте программу в паскаль с while. стакан кипятка (100 °с) остыл за первую минуту на а градусов, а каждую последующую минуту остывал на 15% меньше, чем в предыдущую. через сколько минут температура воды станет ниже nо с?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kristinakarpen
03.10.2020 06:15
Var A, gradus, minut, N: real;
Begin
Writeln('Введите A градусов');
readln(A);
Writeln('До какой температуры остужать:');
readln(N);
gradus:=100-A;minut:=1;
While (gradus>N) do
Begin
   A:=A*(1-0.15);
    gradus:=gradus-A;
    minut:=minut+1;
 end;

Writeln('Кипяток остынет до ',N,' градусов через ', minut, ' минут');
readln();
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота