PUPOK2101
08.04.2023 05:47

Составьте программу в паскаль с while. у малыша к банок варенья. в первый день карлсон съел одну банку, в каждый последующий день съедая в 1,5 раза больше, чем в предыдущий. через сколько дней варенье кончится?

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ludarudenko98
30.08.2020 19:23
Var K, den, s_el: real;
Begin
Writeln('Введите K банок');
readln(K);
s_el:=1;
K:=K - s_el;
den:=1;

While (K>0) do
Begin
    s_el:= s_el * 1.5;
    K:=K - s_el;
    den:=den+1;
 end;

Writeln('Варенье кончится через ', den, ' дней');

readln();
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота