гнеуй
29.01.2021 13:16

Сделать в паскале: даны два вектора a=(a1,) b=(b1,) 1)вычислить длины векторов 2)вычислить скалярное произведение векторов 3) вычислить угол между a и b

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Metalmekid
01.06.2022 20:55
Var a: byte; b:integer;
Begin 
writeln('Введите день месяца');
readln(b);
writeln('Введите номер месяца');   
Readln(a);    
          Case a of        
1: writeln(b,' янавря');        
2: writeln(b,' февраля');      
3: writeln(b,' марта ');        
4: writeln(b,' апреля ');      
5: writeln(b,' мая');      
6: writeln(b,' июня ');        
7: writeln(b,' июля');       
8: writeln(b,' августа');     
9: writeln(b,' сентября');     
10: writeln(b,' октября');     
11: writeln(b,' ноября');       
12: writeln(b,' декабря');     
else writeln('Месяца №', a,'нет');   
end;       
end.
0,0(0 оценок)
Ответ:
nastyanas4
21.04.2023 17:11
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота