123443123
23.11.2020 18:25

Написать программу на языке паскаль для нахождения площади треугольника по трем сторонам

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kirillastrovskiy
21.09.2020 15:50
Площадь треугольника по 3м сторонам вычисляется по формуле Герона: \sqrt{p*(p-a)*(p-b)*(p-c)}, где p-полупериметр.
Тогда:

var a,b,c,p:real;
begin
  writeln('Введи длины сторон a, b и c');
  readln(a,b,c);
  p:=(a+b+c)/2;
  writeln('Площадь этого треугольника = ', sqrt(p*(p-a)*(p-b)*(p-c)));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота