sychev66
24.09.2020 18:41

Составить программу в pascal. 3. пусть дано 100 вещественных чисел, которые вводятся по одному. вычисли¬те среднее арифметическое положительных и среднее арифметическое от¬рицательных чисел. 4. напечатать таблицу соответствия между весом в фунтах и весом в кг для значений от 1 до 10 фунтов с шагом 0,5 фунта. формула перевода: 1 фунт = 400 г. 5. составьте таблицу значений функции y = 5x2 – 2x + 1 на отрезке [-5; 5] с шагом 2.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
таня2027
07.08.2020 08:20
1)
   var
 a:array[1..100]of real;
 n,p,q,q1:real;
 i:integer;
   begin
    for i:=1 to 100 do
     begin
      read(a[i]);
      if a[i]>=0 then
       begin
        p:=p+a[i];
        q:=q+1;
       end;
      if a[i]<0 then
      begin
       n:=n+a[i];
       q1:=q1+1;
      end;
    end;
   writeln('positive:',p/q);
   writeln('negative:',n/q1);
 end.

2)
      uses crt;
var
n:real;
i:integer;
 begin
 n:=0.5;
 write('  Pounds','       Kg');
 writeln;
   for i:=1 to 20 do
    begin
    write ('    ',n,'       ', n*0.4);
    n:=n+0.5;
    writeln;
    end;
  
 end.

3)
  uses crt;
var
x:integer;
 begin
  write(' x','        y');
  writeln;
   for x:=-5 to 5 do
   begin
      write(x,'       ');
      write(5*(x*x)-(2*x)+1);
      writeln;
   end;
   end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота