Написать программу с использованием цикла while. через каждые пять секунд каждая амеба делиться на две амебы. изначально была 1 амеба. сколько амеб будет через n секунд? проверить решение для 10, 25, 72 секунд.
Var n,a,time:integer; Begin Readln(n); a:=1;time:=0; while time<n do begin if frac(time/5)=0 then a:=a*2; time:=time+1; //èëè âìåñòî ýòîãî " Inc(time); " End; Writeln(a); End.
И результаты проверки: 10 секунд: 4 амёбы 25 секунд: 32 амёбы 72 секунды: 32768 амёбы
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку