Составить программу для вычисления a - сумма отрицательных элементов массива; b – количество четных элементов массива; c - номер первого положительного элемента массива. полученные значения элементов а,b,c,f вывести на печать. f: =c+((a+b)/(10-c+
Const n=20; var x,y : array[1..n] of integer; i,a,b,c : integer; f:real; begin Randomize; writeln('Исходный массив:'); for i:=1 to n do begin x[i]:=random(101)-50; write(x[i],' '); end; writeln; a:=0; b:=0; c:=0; for i:=1 to n do begin if x[i]<0 then a:=a+x[i]; if x[i] mod 2 = 0 then b:=b+1; if (c=0)and(x[i]>0) then c:=i; end; writeln('A=',a,' B=',b,' C=',c); f:=c+((a+b)/(10-c+a)); writeln('F=',f:5:2); end.