Составить программу в паскаль. с клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. определить: 1.максимальное число в этой последовательности. 2.количество четных чисел.
//Pascal ABC.NET v3.0 сборка 1111 var a,k,max:integer; begin a:=1; max:=-1000; k:=0; while a<>0 do begin; if not(odd(a)) then inc(k); if max<a then max:=a; readln(a); end; writeln('Max=',max,', not odd:',k); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку