minion19
25.09.2020 14:15

Pascal abc написать программу, которая находит сумму целых чисел ,которые больше 100, меньшее 200, кратны 7 и заканчиваются на 1 или 4

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Тэт11
03.10.2020 05:06
Var a2,a,c,sym:
integer;
begin
for a:=100 to 200 do begin
  a2:=a;
  while (a2<>0) do begin
    c:=a2 mod 10;
    a2:=a2 div 10;
  end;
  if (a mod 7 = 0 ) and ((c=1) or (c=4)) then sym:=sym+a;
  end;
  writeln('сумма чисел от sym=',sym);
end.
0,0(0 оценок)
Ответ:
voloseikotatian
03.10.2020 05:06
var sum, i : integer;
begin    
for i := 100 to 200 do  
    if (i mod 7 = 0) and ((i div 100 = 4) or (i div 100 = 1)) then          sum := sum + i;    writeln('Сумма равна ', sum)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота