pveronika0808
04.12.2020 10:42

Составьте программу, которая формирует массив из шестнадцати целых чисел от -20 до 20 и находит в этом массиве индексы элементов, значения которых кратным трём.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
sarvaryusuf99
23.05.2020 18:35

Как-то так...

Program g;
Var
A, B : Integer;
N : Integer;
S : Integer;
z:array[0..16] of integer;
i : Integer;
v:integer;
Begin
A:=(-20);
B:=20 ;
N:=16 ;
For i := 1 To N Do
Begin
S := Trunc(Random(B-A)+A);
WriteLn (i:2,'-е случайное число:',S:4);
End;
begin
writeln('Индексы элементов кратных 3:');
for v:=0 to 16 do begin
z[v]:=random(40)-20;
if z[v] mod 3 = 0 then write(v, ' ')
end;
end;
End. 

0,0(0 оценок)
Ответ:
SETMASTERS
23.05.2020 18:35

var

 i:integer;

 a:array[1..16]of integer;

begin

 for i:=1 to 16 do

begin

 a[i]:=random(40)-20;

 if a[i] mod 3=0 then write(i,' ');

end;

writeln;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота