bassanova46
05.10.2021 09:03

Составьте программу для вычисления косинусов углов треугольника со сторонами a, b, c. указание. примените теорему косинусов: c2=a2 + b2 -2ab * cos α

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
аньён1
07.09.2020 11:45
Var a,b,c,cosa, cosb, cosc:real; 
begin 
writeln('Введите стороны треугольника АВС'); 
read(a,b,c); 
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c); 
cosb:=(sqr(c)+sqr(a)-sqr(b))/(2*c*a); 
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b); 
writeln('Косинус угла А = ', cosa, ' Косинус угла В =', cosb,' Косинус угла C =', cosc); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота