koiiik1p0725i
09.03.2021 09:55

Буду признателен. код на c++: написать программу, которая читает с клавиатуры строку символов, преобразует ее и выводит результат на дисплей. подсчитать количество слов в строке.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
123киівміша
15.09.2020 14:48
#include <iostream>
#include <sstream>
using namespace std;

 int main(){
   string str;
   getline(cin,str); //вводим поток в строку
   stringstream ss(str); //вводим строку в поток, при этом пробел делит слова на отдельные элементы
   int i(0); //счётчик
   while(ss>>str) //пока можно выводить элементы(слова)
    i++;
   cout << i;
   cin.get();
   cin.get();
   return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота