dariyakazakova1
26.03.2021 01:37

Дан одномерный целочисленный массив состоящий из 10 элементов составьте программу определения значемния суммы наибольшего и наименьшего элементов этого массива массив заполнить любым

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Nurlan2010
03.10.2020 03:17
// PascalABC.NET 3.0, сборка 1111
begin
  var a:=ArrRandom(10,-15,25);
  Write('Исходный массив: '); a.Println(',');
  Writeln('Сумма min+max=',a.Min+a.Max)
end.

Тестовое решение:
Исходный массив: -8,-6,15,16,17,21,9,10,-15,19
Сумма min+max=6
0,0(0 оценок)
Ответ:
ivan89052
03.10.2020 03:17
Program Project1;
var i, max, min:integer; mass:array [0..9] of integer;
begin
  randomize;
  for i:=1 to 9 do mass[i]:=Random(100);
  max:=0;
  min:=100;

  for i:=1 to 9 do begin
    if max<mass[i] then max:=mass[i];
    if min>mass[i] then min:=mass[i];
  end;

  writeln('max: ', max);
  writeln('min: ', min);
  writeln('max + min = ', max+min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота