КАТЯ3105
14.07.2022 11:08

Написать программу которая для введённого пятизначного числа выводит количество нулей в нем

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
niggaeasyreal
31.07.2020 13:05
Вот уже писал.
uses crt;
var a,n,i:integer;
begin clrscr;
write('Vvedite chislo: ');
read(a); n:=0;
while a<>0 do begin
if a mod 10=0 then inc(n);
a:=a div 10;
end;
writeln('N=', n);
end.
0,0(0 оценок)
Ответ:
Luuna0111
31.07.2020 13:05
var
   n: integer;
begin
  read(n);
  write(ord(n mod 10 = 0) + ord(n div 10 mod 10 = 0) + ord(n div 100 mod 10 = 0) + ord(n div 1000 mod 10 = 0));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота