зубрильчик
03.04.2020 23:12

Напишите программу, которая находит среди элементов массива, состоящего из n элементов, наименьший элемент и его порядковый номер.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
89232752183
03.10.2020 03:08
Var
a:array[1..1000000]of integer;
i,min,n,c:integer;
   begin
      readln(n);
      for i:=1 to n do
      begin
       read(a[i]);
         if i = 1 then
         min:=a[i];
       if a[i]<min then
        begin
       min:=min+a[i] ;
       a[i]:=min - a[i];
       min:=min - a[i];
         c:=i;
         end;
      end;
    writeln('a[',c,']=',min);
    end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота