ivanalekseev20033
20.02.2022 15:13

(паскаль авс) напишите программу которая в последовательности натуральных чисел определяет максимальное четное число. программа получает на вход количество чисел в последовательности, а затем сами числа. программа должна вывести одно максимальное четное число!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Qwtyt
03.10.2020 02:51
Var a:array [0..1010] of longint;
n,max,i:longint;
begin
read (n);
for i:=1 to n do
read (a[i]);
max:=a[1];
for i:=2 to n do
if ((max<a[i]) and (a[i] mod 2=0)) then max:=a[i];
write (max);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота