Гениально1
15.08.2021 23:47

Дан одномерный массив целых чисел, состоящий из 20 ячеек, заполненный случайными числами из промежутка [-100,90]. увеличить каждый элемент массива на 100. напишите программу со всеми объяснениями

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Stak96
18.09.2020 23:54
Написал две программки на случай, если там все таки массив  определен:
1)
var
a:array[1..20]of integer;
i,n,c:integer;
begin
 for i:=1 to 20 do
  begin
   read(a[i]);
   a[i]:=a[i]+100;
  end;
  for i:=1 to 20 do
  write(a[i],' ');
  end.

2)
var
a:array[1..20]of integer;
i,n,c:integer;
begin
  for i:=1 to 20 do
  begin
   a[i]:=random(191)-100;
   write(a[i],' ');
  end;
  writeln;
  for i:=1 to 20 do
  write(a[i]+100,' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота