GrafGundam
16.12.2021 00:05

Впаскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Анастасия23102002
18.09.2020 21:17
Var a, b, c, x1, x2, D:real;
begin
writeln ('Введите значение a, b и c');
readln (a, b, c);
D:=sqr(b)-4*a*c;
if D>0 then
begin
x1:=(-b+sqrt(D))/2*a;
x2:=(-b-sqrt(D))/2*a;
writeln ('x1 = ', x1, ' x2 = ', x2)end
else
writeln ('Корней нет');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота