panteleevdanil
27.11.2021 00:25

Написать программу, которая вводит десять чисел в одномерный массив, а затем определяет среднее арифмитичне элементов с четными индексами и нечетными индексами

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Првоадыш263
03.10.2020 02:21
Var r,n,m,max,k,el,Sumh,Sumnh:integer;C:Array[0..9]of integer;Sh,Snh:real; 
Begin
for r:=0 to 9 do begin
C[r]:= random(50)-25;  write(C[r]:4);
if r mod 2 = 0 then Sumh := Sumh + C[r]
else Sumnh:= Sumnh + C[r];end;
Sh:= Sumh/5;Snh:= Sumnh/5;writeln;
writeln('среднеарифметическое элемент с четными индексами ',Sh:6:4);
write('среднеарифметическое элемент с четными индексами ',Snh:6:4);end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота