ilike1
19.04.2021 07:15

Составьте программу проверки эквивалентности двух логических функций. постройте соответствующие таблицы истинности(программно). 1.проверьте что x → y эквивалентна not (x) or y

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ЕваЛюцифер
03.10.2020 02:27
//так и не осознала как вводить функции с клавиатуры. С у учителя.
var b1,b2,b:boolean;

function imp(a, b : boolean) : boolean;
begin
imp:=(not a) or b;
end;

begin;
writeln('Implication');
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,imp(b1,b2):7);

writeln('not (x) or y');
For b1:=false to true do
For b2:=false to true do
writeln(b1:7,b2:7,((not b1) or b2):7);

For b1:=false to true do
For b2:=false to true do
if imp(b1,b2)<>((not b1) or b2) then
 begin;
  writeln('Не эквивалентны');
  exit;
 end;
writeln('Эквивалентны');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота