Атабек111111
11.02.2022 11:36

Составить программу, включающую меню из четырех пунктов: 1.создать текстовый файл из пяти строк-предложений. 2.вывести содержимое файла на экран. 3.вывести на экран количество слов, содержащих цифры. 4.выход. первые три пункта меню реализовать в процедурах, которые поместить в модуль. на делфи.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Digger2001
31.07.2020 12:46
{ Запись 5 строк в файл }
procedure TForm1.Button1Click(Sender: TObject);
var outfile: TextFile;
begin
AssignFile(outfile, 'outfile.txt')
;Rewrite(outfile);
writeln(outfile, 'Привет из Delphi');
writeln(outfile, 'Моя программа работает, и выводит '
+'данный текст, чтобы доказать это...');
writeln(outfile, '3. Треться строка');
writeln(outfile, '234 четвертая');
writeln(outfile, 'Пятая строка');
CloseFile(outfile);
end;

// вывод на экран точнее в мемо или лист бокс

procedure TForm1.Button2Click(Sender: TObject);
begin 
// выводим в мемо
 Memo1.Lines.LoadFromFile('outfile.txt');
// либо в лист бокс как тебе лучше
 ListBox1.Items.LoadFromFile('outfile.txt');
end;

// кнопка для закрытия 

procedure TForm1.Button3Click(Sender: TObject);
begin 
Close;
end;

// событие onClose

procedure TForm1.FormClose(Sender: TObject; var CloseAction: TCloseAction);
begin
  if MessageDlg('Вы точно хотите выйти?',     mtConfirmation, mbOkCancel,0)= mrOk then begin     
CloseAction:= caFree;   
     end
  else begin
     CloseAction:= caNone;
  end;
end;

ЗДЕСЬ!
outfile.txt - это ваш файл(может создаваться автоматически

ЧТО НУЖНО СДЕЛАТЬ?
1. Закинуть на форму 3 кнопки
2. Закинуть ListBox или Memo
3. В событиях формы в инспекторе объектов (Инспетор Объектов/ События/ onClose) в onClose выбрать процедуру FormClose
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота