Arisha54
26.06.2020 07:39

1. напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a,b,c) 2. координаты 2-х точек плоскости вводятся с клавиатуры.определите и выведите на экран какая точка расположена дальше от начала координат и на сколько. формат вывода следующий "расстояние от точки а до начала координат больше, чем расстояние от точки в до начала координат на 8,5 единиц" проведите тестирование программы для точек из разных четвертей координатной плоскости.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
akselroddasha
18.09.2020 15:54
1.var a,b,c:integer;
d,x1,x2:real;
begin;
readln(a);
readln(b);
readln(c);
d:=sqr(b)-4*a*c;
if d<0 then
   writeln('Нет корней')
   else
    if d=0 then
     begin;
      x1:=-b/(2*a);
      writeln(x1);
     end
      else
       begin;
        x1:=(-b+sqrt(d))/(2*a);
        x2:=(-b-sqrt(d))/(2*a);
        writeln(x1);
        writeln(x2);
       end;
end.
2)var x1,y1,x2,y2:integer;
r1,r2,rr:real;
begin;
readln(x1);
readln(y1);
readln(x2);
readln(y2);
r1:=sqrt(sqr(x1)+sqr(y1));
r2:=sqrt(sqr(x2)+sqr(y2));
if r1>r2 then
 begin;
  rr:=r1-r2;
  write('Расстояние от точки А до начала координат больше, чем расстояние от точки В до начала координат на ',rr,' единиц');
 end
  else
   if r1<r2 then
    begin;
     rr:=r2-r1; 
    write('Расстояние от точки B до начала координат больше, чем расстояние от точки A до начала координат на ',rr,' единиц');
    end
     else
      write('Точки A и B равноудалены от начала координат');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота