arturlatipov
10.04.2022 09:09

Составить программу для ввода в эвм произвольной вещественной матрицы размером m*n и вывода первого не равного заданному s элемента каждой строки. написать программу в pascalabc.net

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
яяя612
03.10.2020 01:49
var
  m, n, i, j: integer;
  s: real;
  a: array[,] of real;
 
begin
  write('Введите S: ');
  read(s);
  write('Введите M, N: ');
  read(m, n);
  setlength(a, m + 1, n + 1);
  writeln('Введите элементы матрицы: ');
  for i := 1 to m do
    for j := 1 to n do
      read(a[i, j]);
  for i := 1 to m do
  begin
    for j := 1 to n do 
      if a[i, j] <> s then
      begin
        writeln(a[i, j]);
        break;
      end;
    if a[i, j] = s then
      writeln('-');
  end;
end.

Пример:
Введите S: 7
Введите M, N: 3 4
Введите элементы матрицы:
7 4 3 7
3 5 1 4
7 7 7 7
4
3
-
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота