Sobakopes
19.12.2021 11:11

Напишите программу, которая выводит последнее слово переданной её символьной строки. слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. входные данные входная строка содержит произвольную последовательность символов. выходные данные программа должна вывести последнее слово этой строки. примеры входные данные abra babra cadabra выходные данные cadabra

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
yuiopaw
03.10.2020 01:38
Program z1;  Var i,b,j,n:integer; s,space,h:string;      a: array [1..1000] of string;Begin  write('Введите текст - ');  readln(s);  b:=length(s);  space:=' ';  i:=1;  n:=0;  j:=1;  while i<=b do  begin    h:='';    while s[i]<>space do    begin      h:=h+s[i];      i:=i+1;    end;    a[j]:=h;    j:=j+1;    i:=i+1;    n:=n+1;  end;      write(a[n],' ');  End. Только в конце предложения ставь тоже пробел!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота