abra123
31.10.2022 05:51

Напишите программу, запрашивающую у пользователя n целых чисел и выводящую на экран: а) количество нулей в последовательности; б) количество положительных чисел; в) количество отрицательных чисел. ( на языке паскаль с++)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Настька1210
03.10.2020 01:42
Program z1;  Var i,n,a,b,c:integer;      m: array [1..1000] of integer;Begin  write('Введите кол-во чисел - ');  readln(n);   randomize;   a:=0;   b:=0;   c:=0;  for i:=1 to n do  begin    m[i]:=random(100)-50;    write (m[i],' ');  end;    for i:=1 to n do    if (m[i]=0) then a:=a+1;      for i:=1 to n do    if (m[i]>0) then b:=b+1;      for i:=1 to n do    if (m[i]<0) then c:=c+1;  writeln;  writeln ('Кол-во нулей - ',a);  writeln ('Кол-во положительных чисел - ',b);  writeln ('Кол-во отрицательных чисел - ',c);End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота