NarGog
26.05.2022 17:02

Составьте программу для решения : даны две точки, заданные своими координатами. определить , какая из них находится ближе к началу координат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
инкар03
17.09.2020 18:23
Расстояние от точки до начала координат находится как длина гипотенузы прямоугольного треугольника, катетами которого являются координаты точки. Поскольку нам нужны не сами расстояния, а лишь сравнить их, то можно сравнивать квадраты, чтобы не извлекать корня.r_i^2=x_i^2+y_i^2

// PascalABC.NET 3.0, сборка 1088
var
  x1,x2,y1,y2,r1,r2:real;
begin
  Write('Введите координаты первой точки: '); Read(x1,y1);
  Write('Введите координаты второй точки: '); Read(x2,y2);
  r1:=sqr(x1)+sqr(y1); r2:=sqr(x2)+sqr(y2);
  if r1>r2 then Writeln('Ближе вторая точка')
  else
    if r1<r2 then Writeln('Ближе первая точка')
    else Writeln('Точки равноудалены')
end.

Тестовое решение:
Введите координаты первой точки: 16.3 -11.7
Введите координаты второй точки: 15.8 12
Ближе вторая точка
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота