shenjaaoy169t
17.01.2023 08:50

Даны целое трехзначное число n и цедое число k. написать программу, подсчитывающую сумму цифр числа n, которые больше k

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GeorgYanovski777
17.09.2020 16:24
Var N,k,sum : Integer;
Begin
  sum:=0;
  Readln(N,k);
  While N>0 do
  Begin
   If (N mod 10)>k then sum:=sum+(N mod k);
   N:=N div 10;
  end;
end.

или так

Var N,k,sum : Integer;
Begin
  sum:=0;
  Readln(N,k);
  While N>0 do
  Begin
   sum:=sum+(N mod 10)*Ord((N mod 10)>k);
   N:=N div 10;
  end;
end.

или так

Var N,k : Integer;
Function sum(N,k : Integer) : Integer;
Begin
  If (N>0) and ((N mod 10)>k) then sum:=(N mod 10)+sum(N div 10,k) else sum:=0;
end;
Begin
  Readln(N,k);
  Writeln(sum(N,k));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота