ТАлександра
20.07.2020 22:07

Нужно составить программу с repeat,определяющую максимальное из всех введённых вами чисел.(пусть признаком конца ввода чисел является введённое число 0).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ьпоаь1
26.05.2020 23:20

var
i, e : Integer;
begin

Writeln('Вводите числа:');

i := 0;

repeat
Readln(e);

if e > i then i := e;
until e = 0;

Writeln('Наибольшее число: ', i);

end.

0,0(0 оценок)
Ответ:
милана5555555
26.05.2020 23:20

Program abc;

uses crt;

const n=30;

var

a:array[1..n] of integer;

i, max:integer;

begin

clrscr; 

for i:=1 to n do

read(a[i]);

max:=a[1];

for i:=2ton do

if a[i]>max then max:=a[i];

write('max=',max);

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота