vadimrusackeviVadim
07.05.2021 14:58

Написать программу которая даст таблицу q5*5. каждый эелемент таблицы случайное число из отрезка [-30,+30]. вычислить сумму все отрицательных и сумму положительных элементов.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
asdfghjkl12347
26.05.2020 22:51

var a,b,i,j,p,o: integer;
z:real;
m:array[0..31,0..31] of integer;
begin
randomize;
for i:=1 to 5 do
for j:=1 to 5 do
begin
z:=random;
b:=random(31);
if z<0.5 then m[i,j]:=b;
if z>0.5 then m[i,j]:=-b;
end;
for i:=1 to 5 do
for j:=1 to 5 do
begin
if m[i,j]>0 then p:=p+m[i,j];
if m[i,j]<0 then o:=o+m[i,j];
end;
write(p,' ',o);
end.

 

мда. подумать над задачкой пришлось немного) но вот результат)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота