usereldoc9857
11.05.2022 17:06

На вход программе подается натуральное число n < = 109. проверьте, является ли оно простым. выведите yes или no в зависимости от ответа на вопрос . максимальное время работы программы на одном тесте — 0,1 секунды.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dshmz
17.09.2020 12:06
Var
a,flag,i:integer;
Begin
Readln(a);
flag:=0;
for i:=2 to a do begin 
if i<>a then if a mod i=0 then 
begin flag:=1; break; end;  end;
if flag=1 then Writeln('NO')
else Writeln('YES')
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота