polykanasch201
09.12.2021 01:12

Написать программу в pascal. переписать сведения о багаже из переменной bagaj в переменную bag. в переменной bag сведения о багаже каждого пассажира представляются массивом из двух целых чисел - числа вещей и общего веса вещей, выраженного в граммах. составить также программу обратного преобразования: переписи сведений о багаже из переменной bag в переменную bagaj.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
viceofficial
15.09.2020 12:29
// PascalABC.NET 3.0, сборка 1073
var
  Bag,Bagaj:array[1..2] of longint;
begin
  Bagaj[1]:=5; Bagaj[2]:=43600;
  { перенос Bagaj -> Bag }
  Bag[1]:=Bagaj[1]; Bag[2]:=Bagaj[2];
  Writeln('Предметов- ',Bag[1],', общий вес ',Bag[2]);
 
  Bag[1]:=4; Bag[2]:=24540;
  { перенос Bag -> Bagaj }
  Bagaj[1]:=Bag[1]; Bagaj[2]:=Bag[2];
  Writeln('Предметов- ',Bagaj[1],', общий вес ',Bagaj[2]);
end.

Тестовое решение:
Предметов- 5, общий вес 43600
Предметов- 4, общий вес 24540
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота