seregatarlykov
23.05.2023 08:45

1.с клавиатуры вводят слово и символ.составьте программу ,которая определяет позицию данного символа.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
annyakristina
23.05.2020 18:15

Var c: Char;
s: String;
i,k,p: Integer;
Begin
ReadLn(c); {Чтение заданного символа}
ReadLn(s); {Чтение заданного слова}
p:= Pos(c,s); {Определяем позицию символа}
If (p=0) Then {Функция вернёт 0, если символ не будет найден}
WriteLn('Такого символа в слове нет.')
Else {Если символ есть, то ...}
Begin
WriteLn('Указанный символ расположен на позиции: ',p);
k:= 0; {k хранит количество вхождений}
p:= Length(s); {p хранит длину строки(слова)}
For i:=1 To p Do {Пробегаем по всем символам слова}
If (s[i]=c) Then inc(k); {Если символ совпадает, увеличиваем на 1 переменную k}
WriteLn('Количество вхождений данного символа: ',k);
End;
End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота