karrygreenk
14.11.2022 01:50

Написать программу в turbo pascal найти 2 максимума из любой последовательности чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
hades77
02.10.2020 23:46
Var ar:array[1..30] of integer;
i,max,max2,maxp,maxi:integer;
begin;
randomize;
writeln('Array');
for i:=1 to 30 do
begin;
ar[i]:=random(1,100);
write(ar[i]:4);
end;
for i:=1 to 30 do
if max<ar[i] then
begin;
maxp:=max;
max:=ar[i];
maxi:=i;
end;
ar[maxi]:=maxp;
for i:=1 to 30 do
if max2<ar[i] then max2:=ar[i];
writeln;
writeln('Max1:',max);
writeln('Max2:',max2);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота