Составьте программу вывода на экран n первых чисел фибонаги (это числовая последовательность 1,1,2,3,5,8, вычисляются по правилу: а1=1,а2=1,а3=а2+=аn-1+an-2(после -а- это ! )pascal abc
Var i,n:integer; a,b:int64; begin read(n); a:=1; b:=1; if (n=1) then write(a) else if (n>=2) then write(a,', ',b); if (n>2) then for i:=1 to n-2 do begin b:=b+a; a:=b-a; write(', ',b); end; End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку