lisa17012006
16.08.2021 23:53

Написать программу, от пользователя число (номер года) и выводящую информацию о том, високосный этот год или нет

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
софа336
16.09.2020 10:48
В григорианском календаре високосным является:
- год, номер которого делится нацело на 400
- год, номер которого делится на 4, но не делится на 100
Программа на паскале:
var n: integer;
begin
  read(n);
  if (n mod 400 = 0) or (n mod 4 = 0) and (n mod 100 > 0)
  then writeln(n, ' год високосный')
  else writeln(n, ' год невисокосный');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота