romab07
04.10.2021 19:15

Как в бейсике написать программу домик с горящим окном?

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kazakstanarmy
06.03.2021 05:44

1)  В котором  действия выполняются последовательно одна за одной

2) Цикл может выполнятся несколько раз

3) Розгалудження - условия при которых выполняется определенный фрагмент кола. То есть  if else

4) 1. if(если).  if(a==10) writeLine (a)  если условие верно - действие выполняется иначе данный код игнорируется. такое называется "Неповне розгалудження"

   2. if(если)  else(иначе).   if(a==10) writeLine (a)  else writeLine (b)   - если условие верно код выполняется иначе выполняется другой код.

Такое называется "Повнеповне розгалудження"

5) Характерне наявнистю умовы та послидовнистю команд в залежности вид умовы.

6) Линейный выполняется последовательно, а розгалудження дает возможность выбрать какой код будет выполнятся, а какой нет.

7) Розгалудження дает возможность выбрать какой код будет выполнятся, а какой нет. А цикл выполняет код определенное количество раз

Объяснение:

0,0(0 оценок)
Ответ:
ivolapseb
01.07.2020 17:57
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота