kosikoffpasha
04.01.2022 20:41

Написать программу на python с использованием множеств и пересечениямаксим едет на автобусе и, чтобы развеять скуку, придумал себе игру. он смотрит в окно и записывает все номера домов на тетрадный листок. на середине пути он берёт новый листок и продолжает записывать номера. в конце пути он хочет узнать, какие номера встретились ему в обоих списках, и выписывает их на третий листок. если таких номеров нет, то максим считает поездку не удачной и записывает слово empty.формат вводана первой строчке через пробел записаны номера с первого листка. на второй строке через пробел — номера со второго листка.формат выводаномера, встретившиеся на обоих листках в порядке возрастания. если таких номеров нет, надо вывести слово empty.​

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
emv63756
26.05.2020 16:40

def bus():

   leaf_one = []

   leaf_two = []

   while True:

       number_home = input()

       if number_home != 'n':

           leaf_one.append(number_home)

       else:

           break

   print('New leaf')

   while True:

       number_home = input()

       if number_home != 'end':

           leaf_two.append(number_home)

       else:

           break

   c = set(leaf_one)&set(leaf_two)

   if len(c)>=1:

       print(c)

   else:

       print("EMPTY")

bus()

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота