Айхан111111111
23.06.2020 16:17

Написать программу на паскале вывести квадраты и кубы 10 чисел следущей последовательности: 1, 2, 4, 7, 11, 16..

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
adrian55RUS
31.07.2020 01:27
Данная последовательность -- последовательность центральных многоугольных чисел. Вычисляется по формуле a(n) = n*(n+1)/2 + 1. Или a(1) = 1, a(n+1) = a(n) + n.

Var
  a, i: integer;
Begin
  a := 1;
  for i := 1 to 10 do
  begin
    writeln('base=', a, 'square=', a*a, ' cube=', a*a*a);
    inc(a, i);
  end

End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота