Необходимо написать программу в паскале вставить по одному элементу с заданным значением перед всеми отрицательными элементами массива.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Begzodik
31.07.2020 01:15
Var
  a:array[1..10] of integer;
  n,i:integer;
begin
  readln(n);
  for i:=1 to 10 do begin
    a[i]:=random(-10,10);
    if (a[i] < 0) and (i > 1) then begin
      if a[i-1] > 0 then a[i-1]:=n;
    end;
    if (a[i] < 0) and (i = 1) then write(n:3);
  end;
    for i:=1 to 10 do write(a[i]:3);
end.
0,0(0 оценок)
Ответ:
shiryaevkirill
31.07.2020 01:15
Pascal ABC
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота