strizhnevan
03.02.2022 22:25

Составить программу которая вводит х и у с клавиатуры вычисляет и выводит на экран значение z =9x^4- корень из x+|y| поделить на (y+7) в фарматном виде с двумя знаками после точки

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
shabdanova16
02.10.2020 22:26
Могу предложить на Паскале:

uses Crt;
var x, y, z: real;
begin
 ClrScr;
 Write ('x = '); ReadLn(x);
 Write ('y = '); ReadLn(y);
 if (y<>-7) and (x+abs(y)>=0)
 then
   begin
     z:=9*sqr(sqr(x))-sqrt(x+abs(y))/(y+7);
     WriteLn('z = ', z:4:2);
   end
 else Writeln('None!');
 ReadLn;
end.

Здесь важно учесть, что Y не должен равняться (-7), поскольку на 0 делить нельзя, и X должен быть больше или равен модулю Y, поскольку нельзя извлекать корень из отрицательного числа.

 PS: Если надо решение на Си++, то это сделать просто, основываясь на приведенной выше программе...  
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота