Ррргчг2424
19.09.2021 00:24

Pascal abc. написать программу, которая находит сумму четных элементов массива произвольного размера (размер и элементы массива вводятся с клавиатуры).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vasilevasanka
02.10.2020 22:22
Var
  a:array of integer;
  i,b,c:integer;

BEGIN
  write('Введите размер массива - ');
  readln(b);
  setlength(a,b);
  writeln('Введите элементы массива - ');
  for i:=0 to b-1 do begin
    readln(a[i]);
    if a[i] mod 2 = 0 then c:=c+a[i];
  end;
  writeln('Сумма четных элементов массива  - ',c);
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота