нигич1
24.09.2021 06:56

Написать программу на паскале, (максимально просто)дан массив из 15 элементов, отсортировать по возрастанию элементы массива являющиеся простыми числами.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Каке11
25.03.2019 00:20

program pr10;

uses crt;

var

  i: integer;

  t: real; // рабочая переменная

  i: byte; // счетчик массива

  k: byte; // параметр цикла

  a: array[1..15] of real;

  n: byte; // размерность цикла

begin

  clrscr;

  write('введите размерность: ');

  readln(n);

  writeln('введите ',n,' элементов');

  for i: =1 to n do

      readln(a[i]);

      writeln('исходный массив: ');

  for i: =1 to n do

      write(a[i]: 5: 1,' ');

      readln;

// блок обработки

  for k: =1 to n do

      for i: =1 to n-k do

        if(a[i]> a[i+1]) then

// перестановка

            begin

              t: =a[i];

              a[i]: =a[i+1];

              a[i+1]: =t;

            end;

  writeln('отсортированный массив: ');

  for i: =1 to n do

      write(a[i],' ');

      writeln;

      readln;

end.

я хз как правильно проверить простое число или нет. вот код, который просто сортирует массив по возрастанию.  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота