grange
19.02.2023 07:58

Напишите программу, которая по введенному не более чем 4-х значному числу k будет выдавать сумму его цифр. на входе k(0< =k< =9999).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
янбаян
30.07.2020 11:20
var
k,s: integer;
begin
Writeln('Введите число K:');
Readln(k);
if (k<=9999) and(k>=0) then
begin
if k div 1000 <>0 then
 s:= (k mod 10) + (k div 1000) + ((k  div 100)mod 10) + (k div 10)mod 10;
if (k div 1000 = 0)  and (k div 100 <> 0) then
s:=(k mod 10) +( k  div 100) + (k div 10)mod 10;
if (k div 100 = 0)  and (k div 10 <> 0) then
s:= (k mod 10) + (k div 10); 
if (k div 10 = 0)  and (k mod 10 <> 0) then
s:= k;Writeln('Сумма цифр = ', s);
end;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота