toktasynnazerke
12.03.2022 23:58

Составить программу на паскале. дано натуральное число: а) найти количество четных цифр; б) верно ли, что цифра а встречается в числе более двух раз а вводится с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
omarova4
02.10.2020 21:50
Var a,b,c,c1,a1:integer;
begin
write('введите число => ');
readln(a);
write('введите число а => ');
readln(a1);
c:=0;
c1:=0;
while (a<>0) do begin
b:=a mod 10;
a:=a div 10;
if (b mod 2 =0) then c:=c+1;
if (b=a1) then c1:=c1+1;
end;
writeln('количество чётных цифр =>', c);
if (c1>2) then writeln('а встречается в числе больше двух раз');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота