elena30061984
25.09.2021 19:08

Даны натуральные числа n . составьте программу которая вычисляет сумму тех элементов последовательности которые кратны 3м

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
xammatovrunar
02.10.2020 21:47
Const n=100;
var a: array [1..n] of integer;
    s,i: integer;
begin
  s:=0;
  for i:=1 to n do 
{ вывод массива на экран  }
  begin 
    a[i]:=Random(100);
    write(a[i],' ');
    if (i mod 10 =0) then writeln();
  end;
 { подсчет суммы элементов, кратных 3 }   
  for i:=1 to n do   
      if (a[i] mod 3 =0) then s:=s+a[i]; 
 writeln('сумма равна   ',s);
end.             
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота