Maximys2001123
02.06.2022 20:03

Написать программу, которая вводит с клавиатуры одномерный массив из 5 целых чисел и выводит количество ненулевых элементов. перед вводом каждого элемента должна появляться подсказка с номером. рекомендуемый вид экрана при работе программы: после ввода каждого числа нажмите a[1]= 12 a[2]= 0 a[3]= -3 a[4]= 1 a[5]= 0 в массива 3 ненулевых элемента

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
trofimovigor07
30.07.2020 00:02
Program p1;
var a:array[1..5] of integer;
    i,c:integer;
begin
for i:=1 to 5 do
begin
writeln('Введите a[',i,']: '); read(a[i]);
if a[i]>0 then c:=c+1;
end;
writeln('В массива ',c,' ненулевых элемента');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота